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1.1 Introduction to Altium Designer 

Underlying the Altium Designer environment is a software integration platform that brings 

together all the tools necessary to create a complete environment for electronic product 

development, in a single application.  

Altium Designer includes tools for all design tasks: from schematic and HDL design capture, 

circuit simulation, signal integrity analysis, PCB design, and FPGA-based embedded system 

design and development. In addition, the Altium Designer environment can be customized to 

meet a wide variety of user requirements.  

1.1.1 The Altium Designer Integration Platform 

When you select All Programs » Altium Designer Summer 09 from the Windows Start menu 

to run Altium Designer, you are actually launching DXP.EXE. The DXP platform underlies Altium 

Designer, supporting each of the editors that you use to create your design.  

The application interface is automatically configured to suit the document you are working on. 

For example, if you open a schematic sheet, appropriate toolbars, menus and shortcut keys are 

activated. This feature means that you can switch from routing a PCB, to producing a Bill of 

Materials report, to running a transient circuit analysis, and so on – and the correct menus, 

toolbars and shortcuts will be readily available.  

Also, all toolbars, menus and shortcut keys can also be configured to suit how you like to 

configure your design environment. 

Figure 1. Altium Designer’s software integration architecture 
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1.2 The Altium Designer environment 

The Altium Designer environment consists of two main elements:  

• The main document editing area of Altium Designer, shown on the right side in .  Figure 2

Figure 2. Altium Designer with the DXP Home Page displayed. 

• The Workspace Panels. There are a number of panels in Altium Designer, the default is that 

some are docked on the left side of the application, some are available in pop-out mode on 

the right side, some are floating, and others are hidden.  

When you open Altium Designer, the most common initial tasks are displayed for easy selection 

in a special view, called the Home Page. 

 

s 

t 

Document bar 

A tab appears for 
each open document.

DXP System Menu 

Use this menu to set 
up system preference
and customize the 
environment. All other 
menus and toolbars 
automatically change 
to suit the documen
being edited. 

View Navigation 

Click on the arrows 
to go back and forth 
between views. 

Workspace panels 

More pop out panels 
are displayed by 
clicking on these tabs. 
These panels can also 
be moved, docked or 
clipped. 

Workspace panels 

These include Files 
and Projects panels. 
These panels can be 
moved, docked or 
clipped by clicking on 
the panel title and 
dragging it to a new 
location. 

Click on the tab at the 
bottom of the panel to 
display its contents.  

Home Page Design View 

Common tasks are listed 
to get started quickly. 

Panel Control 

Editor specific and 
shared panels can be 
displayed using these 
Panel buttons.  

Note: To move an individual panel, click and hold on the panel name. To move a set of panels, 

click and hold on the panel caption bar away from the panel name. To prevent panels stacking 

together, hold the CTRL key. To change a docked panel to pop-out mode click the small pin 

icon at the top of the panel, to change it back to docked click the pin icon again. 

 

Note: If you manage to completely ruin your panel layout and wish to revert back to the factory 

settings, this can be done by going to the View » Desktop Layouts » Default. It’s best to 

restart Altium Designer when you run this. To save a custom layout go to View » Desktop 

Layouts » Save Layout. To reload existing layouts go to View » Desktop Layouts » Load 

Layout. 
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Figure 3. The open project is displayed in the 

Projects panel. 

1.2.1 The Altium Designer Project 

• The basis of every electronic product design is the project.  

• The project links the elements of your design together, including the source schematics, the 

PCB, the netlist, and any libraries or models you want to keep in the project.  

• The project also stores the project-level options, such as the error checking settings, the 

multi-sheet connectivity mode, and the multi-channel annotation scheme.  

• There are six project types – PCB projects, FPGA projects, Core Projects, Embedded 

Projects, Script Projects and Library Packages (the source for an integrated library).  

• Altium Designer allows you to access all documents related to a project via the Projects 

panel. 

• Related projects can also be linked under a common Workspace, giving easy access to all 

files related to a particular product your company is developing.  

• When you add documents to a project, such as a schematic sheet, a link to each document 

is entered into the project file. The documents can be stored anywhere on your network; they 

do not need to be in the same folder as the project file. If they do exist in a directory outside 

where the project exists or its sub-directories, then a small arrow symbol appears on the 

document’s icon in the Projects panel. 

1.2.2 Demo — Opening an existing Project 

1. Select the File » Open Project menu to 

display the Choose Project to Open dialog. 

2. Navigate to the project folder, 4 Port 

Serial Interface, located in the 

\Altium Designer Summer 

09\Examples\Reference Designs 

directory. Locate 4 Port Serial 

Interface.PRJPCB (the project file) and 

double-click on it to open it.  

3. The design will now be listed in the navigation 

tree of the Projects panel. 

4. Click on the – signs to contract the folders.  

5. Click on + (plus) signs to expand folders. 

6. Right-click on the project name (4 Port Serial 

Interface.PrjPcb) to display the context 

sensitive Projects menu.  
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1.2.3 Editor View 

Each different document kind is edited in an appropriate Document Editor, for example the PCB 

Editor for a PCB document, Schematic Editor for a schematic document, or VHDL Editor for a 

VHDL document. Figure 4 shows a schematic open for editing in the Schematic Editor. 

 

Figure 4. A schematic open for editing in the Schematic Editor View. 

1.2.3.1 Document Tabs in the Documents Bar 

Documents that are open are allocated a tab at the top of the application. Click on the relevant 

tab to display that document and make it the active document for editing.  To switch between 

documents the Ctrl + Tab shortcut can be used. You can also tweak how Ctrl + Tab works in the 

preferences. 

 

Figure 5. Tabs showing various documents open, note how the PCB tab is highlighted, indicating that it is 

the document currently being edited. 

Right-click menu in the Documents Bar 

1. Right-click on any document tab in the Documents bar.  

2. Select Tile All from the floating menu that appears. All the opened documents are tiled in 

multiple screen regions. 

Note: The number of opened documents determines the number of regions. 

3. Right-click on a document tab. 

4. Select Close from the menu. 
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5. Position the cursor at the point where two regions of a split screen meet and a double-

headed arrow will display. Click and drag to resize. 

6. Right-click on any one of the tabs in the tiled display and choose Merge All. Notice that you 

have converted a split screen back to a single view. 

Note: Altium Designer supports multiple monitors. If your PC has multiple monitors you can 

use the Open in New Window command when you right-click on a document, or just drag and 

drop on to the second monitor and this will cause it to open in a separate Altium Designer 

application frame. 

 

The right click menu also has options for saving and hiding individual documents as well as 

groups of documents like groups of schematics. 

Note: There are a few options that you can tweak to gain more control of how the document 

bar works in Altium Designer. To do this go select DXP » Preferences and open the System – 

View page. At the bottom right is the Documents Bar section where things like auto hide, multi-

line, ctrl-tab to switch can be set up. 

 

 

Figure 6. Document Bar options in Preferences 

 

1.2.4 Exercises — Navigating around Altium Designer 

1.2.4.1 Using the Projects panel 

1. Open 4 Port Serial Interface.PRJPCB, located in the \Altium Designer 

Summer 09\Examples\Reference Designs\4 Port Serial Interface folder. 

2. Expand and then contract the contents of the navigation tree. 

3. Double-click on a document in the Projects panel to open it. 

4. Double-click on a few more documents in the Projects panel to open them. 

5. Right click on the documents bar to see all the options. 

6. Tweak some of the settings in preferences and see the results. 
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1.3 Document Editor Overview 

To display a document in its editor, double-click on a document icon in the Projects panel. The 

document will be opened in the appropriate editor, e.g. Schematic Editor, PCB Editor or the 

Library Editors.  

When you create a new document in a design you are required to select a document type, e.g. 

Schematic or PCB. The document type you select determines which editor is assigned to the 

document.  

1.3.1 Working in a document editor 

The sections below describe various elements in the user interface of the Altium Designer 

document editors. 

 

ject. 

dified. 

tions. 

nt. 

Menus

Toolbars

Schematic Editor 
displaying the active 
schematic document. 

The Projects panel 
shows all open projects, 
and all documents in 
each pro

Icons to the right of each 
document indicate if that 
document is open, 
hidden and/or mo

Context-sensitive 
right-click pop-up 
menu

The Clear button will clear any 
filter that has been applied to 
the docume

The Mask Level button allows you 
to change the level of dimming of 
unmasked objects. Click Clear to 
clear the current mask. 

The Selection Memory 
button saves selec

The Highlight button allows you to 
click to highlight nets, press Space or 
Shift Space to change the behavior. 

Workspace panels 

Click on these buttons 
to display the various 
workspace panels. 

Status bar 

Figure 7. Schematic Editor Workspace 

1.3.1.1 Menus 

• Altium Designer menus are similar to standard Windows menus. 

• Standard operations, e.g. opening, saving, cut, paste, etc. are consistent across editors.  

• Right-click on an empty space on the menu bar or a toolbar caption to open the 

Customization Editor and customize any of the resources for that editor. 

1.3.1.2 Shortcut keys and pop-up menus 

• Menu commands can also be accessed using shortcut keys. The underlined letter indicates 

the shortcut key for a menu command, e.g. press F for the File menu. 
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• Special shortcut keys give direct access to both menus and sub-menus in the graphical 

editors, e.g. pressing F in the Schematic Editor will pop up the File menu and pressing S will 

pop up the Select sub-menu. 

Note : You can gain a list of every shortcut that is available in Altium Designer by looking 

for a document named GU0104 Shortcut Keys.PDF located in the Help directory of the 

Altium Designer Installation. 

1.3.1.3 Toolbars 

• Toolbars can be fixed to any side of the workspace or they can be floated.  

• Click and drag to move a toolbar. The cursor must be within the toolbar but not actually on a 

button. 

• Toolbars can be reshaped, hold the cursor over the edge of the toolbar and when the 

resizing cursor appears click and hold to reshape. 

• New toolbars can be created and existing toolbars edited.  

• Multiple toolbars can be active, right-click on a toolbar to pop up the toolbar display control 

menu. 

1.3.1.4 System and Editor Panels 

• Altium Designer uses two types of panels – system-type panels, such as the Files, Messages 

or Projects panels that are always available, and editor panels, such as the PCB, schematic 

library or PCB library panels that are only available when a document of that type is active. 

• Panels can float, or be docked, on any edge of the Altium Designer workspace. Docked 

panels can be pinned open, or set to unpinned, where they pop out when their name button 

is clicked. 

• 
s a set by clicking and dragging on the area of panel title bar that contains 

no text or icons. 

• revented from docking on particular edges. Right-click on a panel title bar to 

 

• ivided by separators and a set of panel 

 three display fields are: 

ition 

Panels can be clipped together in a set by dragging and dropping one on another, and then 

dragged around a

• A panel can be unclipped from a set by clicking and dragging on the panel name. 

Panels can be p

configure this. 

 

nimation of panels 
on slower machines. 

Figure 8. Configuration for panel control 

Note : The hide and display speed of 
unpinned panels is configured in the 
System – View page of the Preferences
dialog (DXP » Preferences). It can be 
useful to turn off the a

1.3.1.5 Status Bar 

• The Status Bar is used to display information to the user. 

The Status Bar consists of three display fields d

display buttons. These

- Cursor pos

- Prompt 

- Options. 

• The fields can be re-sized by clicking and dragging on the separators. 
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• The Status Bar is turned on and off using the menu command View » Status Bar. 

The panel display buttons can be a• dded or removed from the Status bar by clicking on the 

arrow button in the far bottom left. 

• er a toolbar button and leave it stationary for about a second and the 

Tool Tip will appear. 

• es extensive use of context sensitive right mouse menus, including in 

• e menu of commands at 

ight-click locations include: 

 

tions of a panel 

1.3.1.6 Tool Tips 

• Tool Tips provide a brief description of how to use a particular function. 

Position the cursor ov

1.3.1.7 Right mouse click context sensitive pop-up menus 

Altium Designer mak

panels and dialogs. 

Right-click anywhere in the environment to pop up a context sensitiv

the current cursor position. Supported r

- in a document editor, on an object 

- in a document editor, in free space

- in the different sec

- on the Status bar 

- on a toolbar or menu bar 

- In dialogs, especially those with a grid of information. 

 

Figure 9. Context sensitive right mouse menus are available throughout Altium Designer 
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1.3.1.8 Dialogs 

• Dialogs are used to set the parameters for various commands and objects. 

• To move from one field to another in a dialog, press the Tab key or use the mouse. 

SHIFT+TAB takes you in the reverse direction.  

• Most fields will have an underlined character associated with them that can be pressed (in 

combination with the ALT key) as an alternative to a mouse click. 

• When a field is highlighted, typing can overwrite it. 

• You’ll find nearly all dialogs will have a question mark icon in the top right hand corner.  

Clicking on this icon activates the What’s This Help (WTH) feature and will display a brief 

pop-up help message from the next control that you click on. For example, Figure 10 shows 

the WTH for the Type control in the component properties dialog. 

 

Figure 10. Using the What’s This Help icon to gain help in a dialog 

1.3.1.9 Undo/Redo 

• Most commands can be undone or then redone using the Undo  and Redo  toolbar 

buttons. The number of schematic editor and PCB editor undos is set in the Preferences 

dialog (DXP » Preferences). 

• The shortcut keys for Undo are CTRL+Z or ALT+BACKSPACE, and CTRL+Y or 

CTRL+BACKSPACE for Redo. 
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1.4 Working with projects and documents 

A project is a set of documents that together define all aspects of your design: including 

schematic sheets, PCB documents, database link definition files, output job definition 

documents, netlists, and so on. Each project results in a single implementation, for example a 

PCB project results in one PCB design, and a library package project results in a single 

integrated library. 

Each document in the project is stored as a separate file on the hard drive. The project file itself 

is also an ASCII document, which includes links to the documents in the project, as well as 

storing project-level settings. 

 

1.4.1 Creating a new project 

To create a new PCB project: 

1. From the Main Menu, select File » New » Project » PCB Project.  

 

Figure 11. The new project is displayed in the Projects panel 

2. Select Save Project As from the File menu to name and save the project document or you 

can right click on the project in the Projects Panel and select Save Project As. 

3. The new project is ready to add new or existing documents to. 
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1.4.2 Adding a new document to the project 

To add a new document to the project:  

Figure 12. New schematic added to the 

1. Right-click on the Project name in the Projects panel,

and from the Add New to Project sub-menu, select

the document kind, for example, Schematic.

2. Right-click on the new schematic document in the

Projects panel and select Save As to name and save

the schematic.

1.4.3 Adding an existing document  
to a project 

To add an existing document to a project: 

1. Right-click on the Project name in the Projects panel.

2. Select Add Existing to Project in the menu to display the Choose Document to Add to

Project dialog.

3. Navigate to locate required file and select it.

4. Click on Open to add it. The document is added into the currently active project. Note that

when you add a document to a project a link is added in the project file to that document.

The document can be located anywhere on the hard disk (or network).

The document icon graphic indicates which Editor will be used to edit the document, e.g. a PCB 

document will have a PCB icon, indicating that it will be opened by the PCB Editor.  

Note: You can add a document to a project using a two step process. First drag the document 

from the Windows File Explorer into the Altium Designer Projects panel and then when it 

appears as a Free Document, click and drag it into the project. 

1.4.4 Moving or copying a document between projects 

1. Since documents are only linked into the project, you can easily move a document from one

project to another simply by clicking and dragging it.

2. To copy a document to another project, hold the CTRL key as you click and drag.

1.4.5 Removing a document from the project 

To remove a document from a project, right-click on the document icon in the Project panel and 

select Remove from Project.  

Note: The document is not deleted from the hard disk, but it is no longer linked into the project.  
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1.4.6 File management with the Storage Manager 

The Storage Manager is a system panel that allows you to perform a variety of file management 

tasks. When you open the Storage Manager (View » Workspace Panels » System » Storage 

Manager) it presents a folder/file view of the active project’s documents.  

The Storage Manager can be used for: 

• General everyday file management functions such as renaming and deleting files in the 

project or within the active project’s folder structure. 

• Management of Altium Designer backups, using the Local History feature. 

• As a Subversion compliant interface for your Altium Designer projects. 

Note: Right-click in the different regions of the panel for options. 

• As a CVS compliant (Concurrent Versions System) interface for your Altium Designer 

projects. 

• As an SCC (Source Code Control) compliant version control interface for your Altium 

Designer projects. 

• Performing a physical and electrical comparison of any 2 versions in the Local History, or 

the CVS Revision list. 

The Folders view on the left gives access to documents stored in the project folder hierarchy. 

Next to this the File list shows all documents in the selected folder. A number of highlighting 

modes are used to indicate the state of each document, press F1 when the cursor is over the 

panel for information on highlighting.  

 

Figure 13. Use the Storage Manager to manage project files on the hard disk, and to interface to your 

Version control system. 

Note: Press F1 over the panel for access to detailed help. 

 

1.4.7 Including other files in the Altium Designer project 

• You can include any file in your Altium Designer project, as long as the Microsoft Windows 

operating system is aware of the file’s associated editor.  

• Add it to the project as described in section 1.4.3 (you will need to change the file filter to see 

non-Altium file types). The file will appear in the Project structure in the Projects panel, 

under a folder icon titled Documentation. 
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1.4.8 Libraries  

• Libraries can exist as individual documents, for example, schematic libraries containing 

schematic symbols, PCB libraries containing PCB footprint models, discrete SPICE models 

(MDL and CKT), and so on. 

• Altium Designer also supports the creation of integrated libraries. An integrated library is the 

compiled output from a library package. It includes all the schematic libraries in the original 

library package, plus any referenced models, including footprint, simulation and signal 

integrity models. 

• Most of the supplied libraries are provided as integrated libraries and are stored within the 

\Program Files\Altium Designer Summer 09\Library folder. Integrated libraries 

can be converted back to their constituent libraries; simply open them in Altium Designer to 

do this. PCB libraries are also provided in the \Program Files\Altium Designer 

Summer 09\Library\Pcb folder. 

• The Schematic Library Editor and PCB Library Editor are covered during the Schematic 

Capture and PCB Design training sessions. The basics of creating an integrated library are 

also covered. 

Note: You can use Protel 99 SE libraries directly in Altium Designer. Add them to the 

Libraries panel to use them without converting them to the Altium Designer format. Note 

that you will not get all the benefits of the enhanced parameter and model support. 

 

1.4.9 Project Packager 

An Altium Designer project can include many and varied files - source files, libraries, reports, 

data sheets, manufacturing files, etc. The Project Packager Wizard simplifies the task of 

managing and transferring the complete fileset. Guided by the settings you define the Project 

Packager Wizard gathers and packages the project into a portable time and date stamped ZIP 

file. The Project Packager supports: 

• Any situation where your project must be moved, for example is moving it from one site to 

another, or backing up your project for secure storage. 

• Packaging a complete Altium Designer project tree - ideal for linked PCB + FPGA + 

Embedded projects. 

• Packaging a complete Altium Designer Workspace - ideal for designers that include all the 

board designs destined for a company product, in a single Workspace. 

• Managing how directory paths are handled during packaging. 

• Managing how files outside the project folder are handled during packaging. 

• Including/excluding Generated files, such as reports, in the project package. 

• Including/excluding History files (created by Altium Designer's built-in file history/restore 

system). 
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Figure 14. Project packager project choice page 

 

1.4.10 Exercise – Working with projects and documents 

This exercise looks at creating a new project and adding documents to it. 

1. Create a new PCB project in the \Altium Designer Summer 

09\Examples\Training\PCB Training\Temperature Sensor folder and name it 

Temperature Sensor.PrjPCB. We will use this project later during the Schematic 

Capture training session. 

2. Add the following two schematic documents to the project from the \Altium Designer 

Summer 09\Examples\Training\PCB Training\Temperature Sensor folder: 

LCD.SchDoc and Power.SchDoc. Use Add Existing to Project… command from the right 

click menu in the Projects panel. 

3. Save and close the new project Temperature Sensor.PrjPCB. 

4. Check that the documents exist on the hard drive using the Windows Explorer 
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